Document Type | Troubleshooting
Category | Patch/Upgrade
Applicable Product Version | 6FS07
Document Number | TADTS002
Issue
This describes a failure to start the DB due to ilog having root permissions.
After starting the DB, no particular logs appear in sys.log, and the DB does not start, appearing to hang.
Cause
During the DB startup process, it checks the current ilog directory and if it exceeds the defined total size limit (ILOG_TOTAL_SIZE_LIMIT), it deletes the oldest backup directory (or backup file) first. If the directory has ROOT permissions, deletion fails causing the startup to fail.
NoteIf tbboot was previously attempted with root permissions, the ilog folder or files may have been created with root permissions.
Solutions
Grant tibero account ownership to folders or files with ROOT permissions, or to the entire ilog directory, and then start the DB.
[root@localhost:/home/tibero/tibero_dump/tibero1/log]> chown -R tibero:tibero ilog [root@localhost:/home/tibero/tibero_dump/tibero1/log]> su - tibero Last login: April 7 17:28:06 KST 2025 on pts/0 [tibero@localhost ~]$ tbboot Tibero 6 TmaxData Corporation Copyright (C) 2008-. All rights reserved. Tibero instance started up (NORMAL mode).
Note
If a patch exists, a โPermission deniedโ error occurs as shown below.Granting permission for MOB_APU to execute COM.FN_CSYS_DECODE SQL> GRANT EXECUTE ON COM.FN_CSYS_DECODE TO MOB_APU;