Document Type | Troubleshooting
Category | Administration
Applicable Product Versions | 6FS06, 6FS07
Document Number | PADTS004
Issue
Although physical files exist in the archive path, the ProSync extraction log may show "archived log not found," causing synchronization to stop and resulting in an issue where the archive cannot be found.
Cause
Only up to 500 archive sequences are stored by default in the v$archived_log view. If the sequences needed for synchronization roll over and disappear, synchronization becomes impossible.
Solutions
1. Workaround by Reference Bypass
Create a temporary view in the source prosync user that references v$archive_dest_files. This forces the prosync user to reference v$archived_log, bypassing the issue.
CREATE OR REPLACE FORCE VIEW PROSYNC_XX_TO_US.V$ARCHIVED_LOG (NAME, THREAD#, SEQUENCE#, FIRST_CHANGE#, FIRST_TIME, NEXT_CHANGE#, RESETLOGS_CHANGE#, RESETLOGS_TIME) AS SELECT "NAME", "THREAD#", "SEQUENCE#", "FIRST_CHANGE#", "FIRST_TIME", "NEXT_CHANGE#", "RESETLOGS_CHANGE#", "RESETLOGS_TIME" FROM SYS.V$ARCHIVE_DEST_FILES;
2. Restart After Applying
After applying all archives, drop the temporary view and restart ProSync.
DROP VIEW PROSYNC_XX_TO_US.V$ARCHIVED_LOG;
NoteIf the temporary view is not dropped and used, because the structure of V$ARCHIVE_DEST_FILES and V$ARCHIVED_LOG views differ, the following error may occur in sys.log.[06-30T13:27:42.026731] [FRM-128] [I] THROW. ec=ERROR_CACHE_FILE_OPEN_FAILED(-1003) [ Unable to open file /DBMS/PCMLAS/LOG/ARCH/log-t0-r0-s70617.arc. ] (csr_id:5055)