Document Type | Technical Information
Category | Administration
Applicable Product Versions | 5SP1FS01, 5SP1FS02, 5SP1FS03, 5SP1FS04, 5SP1FS06, 6FS01, 6FS02, 6FS03, 6FS04, 6FS05, 6FS06, 6FS07
Document Number | TADTI031
Issue
When querying V$SESSION due to reasons such as SESSION KILL, the SERIAL# value may be displayed as a negative number.
Below is an example of this phenomenon.
Below is an example of this phenomenon.
SQL> select sid, serial# from v$session; SID SERIAL# ---- ----------- 130 -2138093902
Cause
Although the SERIAL# value is internally managed as an unsigned int, it is implemented to be converted to an int when storing the value in the _vt_session table. As a result, if the unsigned int value exceeds INT_MAX (2,147,483,647), it is displayed as a negative number during the int conversion process.
Solutions
By applying patch FS07_227758a, the SERIAL# value has been corrected to display properly.
CautionApply the patch through technical support provided by Tmax Tibero.
NoteYou can work around this issue by adding 4294967296 to the SERIAL# value displayed as negative to convert it to the correct value.SQL > alter system session kill (130, 2156873394); System altered.