Document Type | Troubleshooting
Category | Monitoring/Inspection
Applicable Product Version | 6FS06
Document Number | TMOTS018
Issue
An issue has occurred where the DB Time and Per Call items in TPR are output as negative values.
TPR Example
======================================== Report Instance Cnt : 1 (from Instance NO. '5') Elapsed Time : 60.00 (mins) DB Time : -241.52 (mins) Avg. Session # : 31.17 ================================================================================ 3.2 TAC Statistics Overview ================================================================================ Cluster Cache Activity ========================== Per Second Per TX Per Exec Per Call --------------------------------------------------------- --------------- --------------- --------------- Cluster Cache blocks received: 691.86 8,648.20 4,646.79 -6.11 Cluster Cache blocks served: 710.71 8,883.83 4,773.40 -6.28 INC messages received: 3,675.96 45,949.47 24,689.26 -32.46 INC messages sent: 3,612.25 45,153.09 24,261.36 -31.90 Interconnect traffic (KB): 45,421.75
Cause
In TPR, DB Time (Total Request Time) and Total Request Count are calculated as the sum of the difference between the Request and Response times for each DB Foreground session.
This calculation uses the JC_MSG_CL_CONN_REQ_TOTAL value, and the DB Time / Total Request Count for each snapshot is derived using the following formula.
DB Time / Total Request Count Calculation Formula: Current JC value โ Previous snapshot JC value
In other words, the causes of the DB Time and Per Call items showing negative values are as follows.
- Even though one hour has passed since the last snapshot, the current JC value is smaller than the previous snapshot JC value.
- It could be a memory issue, but since the JC value resets upon reboot, if a DB down or recovery occurred between snapshots during this process.
Note
JC_MSG_CL_CONN_REQ_TOTAL: The total number of connection request messages received from clients.
JC: jcnt (information to record the time consumed or the number of times a specific section was executed; wait events record information about periods when the system was actually waiting) system event.
Solutions
When DBTime and Per Call items show negative values in TPR, it is necessary to check the DB status to determine if there was a DB down or recovery situation.