Document TypeㅣTroubleshooting
CategoryㅣAdministration
Applicable Product Versionㅣ6FS06, 6FS07
Document NumberㅣTADTS067
Issue
When collecting callstack dumps for Tibero Error codes, the dump files are not being saved.
Cause
Each time iparam is changed, the configured Error codes are reset as shown in the example below, causing this issue.
- Example: alter system/session set ~
Solutions
Each time iparam is changed, reconfigure the callstack dump setting for Tibero Error codes to resolve the issue.
Reconfiguration Example
SQL> ALTER SYSTEM DUMP CALLSTACK ON ERROR -5074 ON; – When iparam is changed, error codes are reset SQL> ALTER SESSION SET CURRENT_USER=TIBERO; – It is necessary to re-execute the dump collection statement for the error code SQL> ALTER SYSTEM DUMP CALLSTACK ON ERROR -5074 ON; ... – After dump collection, disable with off SQL> ALTER SYSTEM DUMP CALLSTACK ON ERROR -5074 OFF
Note
If dump disabling is not performed after dump collection for error codes, callstack dump files may continue to accumulate.